Re: Comments on yesterday's version of the fresnel document

From: Ryan Lee <>
Date: Thu, 24 Mar 2005 12:53:26 -0500

Emmanuel Pietriga wrote:
> Chris Bizer wrote:
>>> So, where you say:
>>> /********************************************************/
>>> foafPersonLens rdf:type fresnel:ClassLens ;
>>> fresnel:lensDomain foaf:Person .
>>> :oldGuys rdf:type fresnel:InstanceLens ;
>>> fresnel:lensDomain
>>> "foaf:Person[foaf:age/* > 60]"^^fresnel:selector;
>>> /********************************************************/
>>> I'd rather say something like (for the reasons mentioned above):
>>> /********************************************************/
>>> foafPersonLens rdf:type fresnel:Lens ;
>>> fresnel:lensInstanceDomain foaf:Person .
>>> :oldGuys rdf:type fresnel:Lens ;
>>> fresnel:lensClassDomain
>>> "foaf:Person[foaf:age/* > 60]"^^fresnel:selector;
>>> /********************************************************/
>>> We can of course change the property names if somebody offers something
>>> better.
>>> What do you think ?
>> Good idea. Yes, I acutally think your solution of encoding the
>> information
>> into the
>> property name is better than to encode it into the class name.
>> It makes Fresnel look less complicated if there are only two basic
>> classes.

+1 to using property names to differentiate scenarios.

>> lensClassDomain is kind of the default behaviour, so we could also
>> just call
>> it lensDomain. Or even better: Just have fresnel:domain
>> (fresnel:classDomain) and
>> fresnel:instanceDomain and use these properties on lenses and styles.
>> There
>> is no real reason to have the word lens or style in the property name.
>> What do you think?
> Also fine with me. But this means that in the Fresnel ontology
> (described in RDFS/OWL), we have to define an rdfs:domain that is the
> union of fresnel:Lens and fresnel:Style. Is that ok ?

This makes implementation more difficult. With the separation of
lensDomain and styleDomain, it was easy to tell which resource was of
which type. Though at the point I was writing that code, it was
encouraged practice to subclass :Lens (no :purpose yet then), so relying
on rdf:type was harder.

This is mostly a matter of ease of implementation, I don't know how much
we care to make that a priority in sorting out the vocabulary. It is
possible to write more code to try to come away with the appropriate
class for a resource.

I also have that personal preference to not collide with well-known
terms (fresnel:domain vs. rdfs:domain), but I can deal...

Ryan Lee       
W3C Research Engineer    +1.617.253.5327
Received on Thu Mar 24 2005 - 17:53:13 EST

This archive was generated by hypermail 2.3.0 : Thu Aug 09 2012 - 16:39:18 EDT